Back to overview
Voltax is Down
Jul 15 at 04:41pm CEST
Affected services
mmsport.voltax.io
Resolved
Jul 15 at 04:41pm CEST
Voltax is unresponsive.
We will update you once back
Affected services
mmsport.voltax.io
Resolved
Jul 15 at 04:41pm CEST
Voltax is unresponsive.
We will update you once back
Affected services
mmsport.voltax.io